I have a s10 that the fuel pump no pump. Placed in a brand-new fuel pump and also it pump for a couple of secs and also quit. All wires test good and no shorts. Negative relay?


You are watching: 1992 chevy s10 fuel pump relay location

*

the does sounds choose the relay is bad but to be sure right here is a guide to help you step by action with indict in the diagrams below to present you how on her car.https://www.rememberingsomer.com/articles/how-to-check-an-electrical-relay-and-wiring-control-circuitCheck out the diagrams (Below). Permit us understand what happens and also please upload photos or videos the the problem.
*

*

*

*

correct I placed in a jumper in ~ the relay and also the fuel pump will certainly run. I placed in a new relay and it resolved it give thanks to you because that the guide.
Fuel pump not working. Have actually replaced it v a brand-new one, no luck. No voltage at grey cable to pump.Have swapped out the relay, no luckHave check the fuse beside the relay, okay. Over there is voltage at the fuse (test light)I have read over there is a location where you deserve to test the circuit by offering a 12 volts jumper which have to then cause the pump to operation (or call you over there is a trouble like a damaged line - grey wire). However I don't understand where this is.Assuming the line is it s okay to the pump, what am I lacking that is maintaining the pump from obtaining power?The engine has actually spark and also so on. Does not run. No code comes up via the scanner.
great morning, fastened a wire diagram because that you come view. You re welcome verify strength to the relay through the vital on because that me and also let me understand the voltage.The primer cable you space talking about was for the larger models and also is no in your truck.Roy
therefore voltage in ~ the ECM B fuse v the fuse removed and the relay in place?Or fuse in place and also relay removed?(Or both, since I'll be appropriate there?)Thanks!
Fuse in place. Test for power to pen 30. The other, 86, must only have voltage v the an essential on for 2 secs as it comes from the pcm. That will keep voltage if cranking.If you jump 30 and also 87, the pump need to run.Roy
This provides sense.My only confusion is top top the to know of the 4 pins. If i unplug the relay, I believe the pins space in a rectangle-shaped set-up whereas the illustration you detailed has them in a linear collection up.I perform recall detect voltage at one of them with the key on.So looking down at where the relay to be removed, indigenous the driver's side fender, who is who?Thank you! man
Look at the bottom that the relay. They need to be marked 30, 87, 86, 85.You run the 12-volt power or pen 30 come 87 i m sorry is the gray cable to the pump.Roy
Okay! We acquired it running. The grounds because that the computer and other electrical's to be rusted and also not working. 218,000 miles in new England go that, sadly.Thanks because that the great information. We have actually printed it every up and tucked the away for future reference. Man
Fuel pump simply stopped take it it out of the tank check the relations an no power, checked the relay & fuses every good, have actually power in ~ the relay, tryed one more relay an quiet no power at the pump, what am i missing?
The computer energizes the fuel pump relay and also relay will de-energized in 2secs. In ~ which time once the car fires up the oil pressure sending unit powers the pump-All you got is 2secs to inspect for strength at the connector. Also see below

*


Engine turns over yet will not start. Did no hear fuel pump running as soon as ignition is only in top top position. Checked fuses and fuel pump relay. Can hear the fuel pump relay click when the ECM B fuse is placed with the ignition in the top top position. Changed fuel pump. Quiet behaves the very same way.


See more: 2006 Nissan Altima Crankshaft Position Sensor Recall, 2006 Altima Hard Crank Recall

I fully forgot to walk in here and update this post after I solved the problem. I was going v some old e-mail and saw wherein I had signed up for this forum and realized that I never ever updated it. So here goes. Over a year later. However, the difficulty was solved in a few days! I had actually taken the bed turn off of the van to do it easier to change the fuel pump. After instead of the fuel pump ns tried to start the truck. No luck, very same as before. Getting to the suggest of offering up. Ns went ahead and put the van bed back on again. I just happened to be sitting in the chauffeurs seat simply wondering what in the people could it is in wrong once I got to down and also for some reason just turned the key. The started! The only thing i can figure is the there was a ground wire that needed to be associated that wasn"t as soon as the bed had been off. Yet anyway, the new fuel pump did resolve the problem and the truck has actually run an excellent this past year.